Bug fixing in Portfolio page

Bug fixing in Portfolio page
0

#1

Hello!

So I’ve just completed my Portfolio page but I’m having some issues that I’m not managing to fix… Here is the list of them, hopefully some of you will help me see a bit more clearly what I’m doing wrong…

1- Bootstraps buttons not working (and I have no idea why… I checked the code again and again and again…)

2 - Trouble with the “container-fluid” feature, especially in the Intro section (the title and the nav bar are doing weird things…) and the Contact page (I would like the 2 sides of the contact section to stay glued together as one element… Is there a way to do that?)

3- In the contact page, the form is not sending to my email

Also, for the nav bar I used text links instead of buttons, mainly cause I had such a hard time editing stylistically the bootstrap buttons… but then I re-read the rules of the project and it states to use “buttons” (also used images for the social media links when it stated to use buttons but that was just cause I had a design idea in mind that I wanted to try out…). Is that considered as “cheating”?

I would be immensely grateful to anyone who helps me with some of these issues…

Here is the page:


#2

Placing the hyperlink tags on the outside of the button tags should fix your button issues


<a href="https://www.facebook.com/mynah.solo" target="_blank"><button class="btn btn-primary btn-lg">Like<i class="fa fa-thumbs-up icons"></i></button></a>


#3

If you’re using Bootstrap you might as well use the NavBar component

Nav Bar


#4

Check out:

Forms

for more information on handling forms, basically you’ll need a server side script to deal with it.


#5

Oh thank you thank you thank you… ok cool will check all that :slight_smile: