Cannot connect thrugh CodeAlly

I completed the World Cup database with 100%, clicked on the freecodecamp icon to submit a link to my public repo and am stuck. Then I try to submit my link, click the “I’ve completed this challenge” button and get the error “You must complete the project first.” When I try to log back into the project by clicking the “Start the project” button, then clicking the “Login to start coding” button, I keep getting the terms of service. I agree, and get an error - pictured - and get redirected back to the freecodecamp project page. Is CodeAlly down, or is this something I need to fix on my end?

I have tried reloading, refreshing the browser, clearing cookies, and restarting my computer.

Bump. I am still locked out the next day.

My progress is saved up to the Worldcup database, but I can no longer enter into the Worldcup database module, or into any past projects I worked on, or anything new. Looking through the forum I don’t see anyone with a similar issue.

Please help!

Can you check and confirm the following:

  • Is your GitHub account set to private somehow?
  • Are you logged in and using the correct Github account?

Once I click on the “Github Login” button in the picture I don’t get the option to enter a login, the error in the bottom flashes and it sends be back to the freecodecamp worldcup project page. Is there some way to reset the github login with Codeally? I cannot seem to find a way to log out and back in.

Clearing your cookies should log you out of codeally. If you want to be more thorough, you could clear all the codeally related storage. I do this by clicking the start project button, when the green login button shows up → open the browser dev tools, going to the storage or application tab, clicking all the different storage (cookies, local storage, etc), and deleting everything from the codeally domains.

You could also just try another browser.

Typically, I would say an error like that might mean that third-party cookies are disabled. Did you disable them at all?

I got it working! Thank you freecodecamp staff for your help! third-party cookies were enabled, but what worked for me was turning off a setting in FireFox called “Enhanced Tracking Protection For This Site”. Either that or something happened in the background.

Thanks again for your help!!