I cant login with GitHub account!

Hello guys. I wish to all of you a happy New Year!!
Im new to FCC i created my account yesterday and my profile is https://www.freecodecamp.com/nikostsigkros.

I have a serious problem with my login to my account through GitHub.
Everytime i press the “Sign in with GitHub” button it gives me an error page:

Website is offline, No cached version of this page is available

Error 504 Ray ID: 31ab4e9a6cea639d • 2017-01-02 04:01:59 UTC
Gateway time-out

Can anyone help me? Did you have the same problem?

1 Like

try another browser and let me know what it says, please. Happy new year by the way :slight_smile:

1 Like

Happy new Year Michael and thank you for your fast answer.

I was running google Chrome where i get this Error message about the Offline website.

I just tried to login through Firefox browser and here the difference is that it loads the GitHub page that ask me to give persmission to FCC so i press the button and then it loads the FCC.com site without signed in though with the message “Oops! Something went wrong. Please try again later”.


are you typing in your github credentials when it loads the github page ?

Hm… You had a duplicate account in our database. I’ve deleted it. Please try logging again and let me know whether it works.


Yes!!! The problem solved now. I can finally login even from both browsers. Thank you very much Mr. Larson.

Thank you all!

1 Like

no problem , glad we could help! happy new year :slight_smile:

Hi there I’m having a similar issue. I had an account before but I can no longer login via github.

I created a new account using my email address associated with the github profile, but now I can’t see my progress.

My github profile. Email code DOT jrgroup at gmail.com

1 Like

Ok it looks like I can’t login into the site using chrome. I’m on firefox now.

1 Like

I’m having the same issue. My profile is https://www.freecodecamp.com/Sophie-AP

1 Like

I cannot log in with GitHub on the FCC main page. Login works on the forum. I get the “Oops something went wrong. Try again later error.”

Any suggestions?


Hey guys, just wanted to also mention that I as well can no longer login with my github account. Is there a fix for this issue?


It is possible that I had a login through G+ from a long time ago, but when I try to use it that doesn’t work either.
Forum and chat login through Github work fine. I tried it on a fresh install of Firefox (and Edge just for kicks), but no difference. What do I try next?

@GabeTHEGeek @justbennett please email me at team@freecodecamp.com with your GitHub username and any other information that might help me located your account and I will do my best to fix this :slight_smile:

1 Like

I’m having this same problem. Recently, I haven’t been able to log into FCC through Github in any computer browser, but on Android, it works fine. Any ideas what might be wrong?

Hi Quincy,

I’m having the same issue. I sent an email to team@freecodecamp.com a couple of days ago with my GitHub and FCC usernames.

I have the same problem. Cannot login with Github & sent an email at team@freecodecamp.com with the necessary details. Can you help me?

Hi all,

I am unable o log on with GitHub. Please assist