Can't get tests to show up

I’m trying to do the project “Build a Random Quote Machine”

My problem is that I can’t find a way to run the tests / see the test suite thing. I’ve tried putting:

<script src="https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js"></script>

in the HTML section. It also has, by default:

https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js

in Pen Settings > JS > Add External Scripts/Pens

Also, I’m got to this CodePen page by clicking the “using this CodePen template” link that’s in the freeCodeCamp project page.

Also I’m aware that any code that’s there rn is a disaster. I’m just trying to get the tests to work.

Thanks for any help.

solution: https://codepen.io/Cerulium/pen/qByNBQP

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36

Challenge: Front End Development Libraries Projects - Build a Random Quote Machine

Link to the challenge:

When I load that pen, I see the green hamburger in the upper left. If I press on that, I see the tests.

I removed the script from the HTML and it still works. The one in the JS settings works. You also need to add react and react-dom there, too.

Here’s a better picture. I didn’t realize it was supposed to be in the bottom but it’s all white. I’m thinking maybe it’s a browser issue.

Also if I click on “Your Work” I see this:

Does it work in other people’s pens?

I can’t find any that have it. Do you have the link to one?

but it seems to be there in your pen. You just need to expand the view area.
You can do it by dragging the window pane up or click on the icon to the right of the settings button and choose a different layout.

Still just white :confused: tried expanding the bottom part with all three views

here is someone else’s codepen , can you see the hamburger menu on the left?

No

can you switch browsers?
or try in incognito mode?
or disable your browser extensions?

I got it to work on mobile. It still didn’t show with all extensions disabled nor in incognito. I guess it’s just some sort of browser issue?

Idk why though, I’ve never had a browser related issue before and I’m just using the most basic common version of Chrome as far as I know

if you click on the console button on the bottom left side, do you see any errors there?
Try to reload the page or try to create a new pen from the fCC project site again as well.

The CodePen console is empty but I found this in the Chrome console, Idk if it means anything:

image

yeah I don’t see any of these errors about the bundle.js files
Can you copy the errors here so they’re not in an image?

Also check your chrome security settings. you need to allow js scripts to run

In Chrome
Click. Settings.
Click Security and Privacy.
Click Site settings.
Click JavaScript.
Select Sites can use Javascript.

bundle.js:575 Uncaught DOMException: Failed to read the ‘sessionStorage’ property from ‘Window’: Access is denied for this document.
at Function.assign ()
at r (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:575:15325)
at Object. (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:575:15349)
at Object. (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:575:15355)
at r (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:1:124)
at Module. (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:584:86133)
at r (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:1:124)
at https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:1:923
at https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:1:933

Sites can use Javascript is checked.

Can you check your security settings again? Make sure third-party cookies are allowed and there is no enhanced security setting?