How do i run a test on

i am not getting that option to run test on my pen in full or any other view.
here is link my tribute page


You can put:

<script src=""></script>

at the bottom of your html and then use the green hamburger in the upper left. Alternatively you could load the js in your settings/js


it worked thank you very much :grinning:

1 Like

Hi to both!

I was having the same problem and I could finally fix it thanks to your contribution with the Tribute page, but now I am having the same problem with the survey form and when I try to implement the solution Kevin mentioned it doesn’t work. So I came back to my tribute page to see what I was doing wrong and it’s not working there either. I try to load it in the js settings but it does not work either.

Also, I see no green hamburger in codepen :frowning: . I would really appreciate it if you could help me. Thanks a lot!

Can you post a link to your pen?

Of course Kevin, here it is

Well, there are some serious problems with your HTML.

For example, you have two opening main tags. You have lines like <div id=emailfield> - that id should be in quotes. There are a lot of little things like that.

But I think the big problem is that you are using a different url. This is what I used:

<script src=""></script>

Hi Kevin,

Thanks a lot for your corrections. Nevertheless, where dud you find that url? In the specifications of the project the one that I find is:

instead of

Should I use yours for all of the upcoming project tests?


1 Like

I think your second link is also correct. I’ve used it without a problem.

both will work the same way as same js file is stored at both the sites.
EDIT: okay so the one provided in the specification is NOT AVAILABLE .
so we are left with the link that kevin provided.


It worked for me too. Thanks you

So right now, <script src=""></script> works only if added at the top of the HTML section of the pen. works only if added to the JS settings as an external source.

If you switch the two, the test suite wont appear.

1 Like

Whenever I run tests on Survey Form, it says you have only completed 2 tests out of 17, even though I have included all the things in the CSS and HTML file.
Can anyone help me to solve this issue?
My pen is here,

I encountered this very same thing early on! You need to select the test suite drop down option that matches the project you’re working on. It looked like you might have been trying to run the ‘Survey Form’ test suite against your Tribute Page project.


Good luck!

1 Like

I was wondering the same thing. Thanks for this one Kevin.

Kevin I added this. I don’t see hamburgers. I went into setting but did know what to do once I got there.

Its a green colour icon present in the top-left corner. Check it!

1 Like

I was getting an error that the should be above the . I continued to get the error when I moved it above . I saw where someone put it at the top so I tried that. I got no html errors but my project disappeared and there is just a blue screen.

Kevin the missing word is script in my last post.

@dianetrotter It should be:

<script src=""></script>

and it really should be placed at the bottom on the line before the </body> tag.