Test "hamburger" not showing in CodePen project

Hi, I am having trouble running the tests within CodePen in the first Build a tribute page project. I have tried both creating a new Pen and simply running the pre-built project. Neither show a way to test the project. Please help, thanks.

Open the FCC example codepen, go to Editor view, in the JS pane click on the little gear icon, the external script they have loaded is the test suite ( https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js). Just add this to your codepen in the same place and your ready to test.

1 Like

Thank you for your reply, I had already made sure it was shown in there. If you look at my screenshot below, you’ll see that the script shows in the JS settings, as well as my HTML section as a script. Any ideas why it isn’t working?

Instead of a screenshot it would be better if you gave us a link to the pen so we could look everything over for ourselves.

You’re right, thank you. Here it is – https://codepen.io/austin-wark/pen/GREzVQm

Perfect. I’m seeing the green hamburger icon for the test suite in the upper left corner.

Really? I’ll paste another screenshot below of my full page, I don’t see anything. Maybe it is a browser settings issue?

I’ve never seen this issue before so I’m not sure what to suggest, maybe someone with more experience might have run into this before.

First, you are including the test suite twice, once in the HTML and once in the JS pane. Get rid of the one in the HTML. You might open up your browser’s dev tools and see if there are any error messages in the console. Also check in the Inspector to see if the test suite is actually there. It is a div with id fcc_test_suite_wrapper and should be located right before the closing body tag. If it is there then there might be some CSS issue that is hiding it that you need to figure out.

Also, in the HTML pane you ONLY want to include the content in the <main> so you can get rid of all those other tags outside of main. If you want to add additional stuff in the head then click on the gear icon in the HTML pain and there is a place to add it. I doubt this is causing your issue with the test suite but you never know.

Tried all of that, I don’t know why it isn’t showing. I’ll give up for now, it’s not required. Thanks for your help and time.

**Update – ** I tried the CodePen in Google Chrome’s Canary Browser and it worked… Weird, it doesn’t work in the stable Chrome release but it does in the Canary version.

The test script works just fine in the stable release of Chrome for me.

It’s more likely an extension you had installed in the other Chrome version that was blocking or interfering with the test script. You can always try running the browser without extensions by running in a private window.

Thanks man, I just realized that’s what did the first time.