Projects - parent pen deleted

Projects - parent pen deleted
0

#1

Hi.

The parent pen has apparently been deleted so while I can still do the projects, I can’t test them.


#2

You just need to delete the tags. you’re pulling the script twice, once in settings, one there.


#3

Hi there,

I can’t figure out what you think has been deleted.

I have forked pens too but they all still work.
Can you put a link to one of your codepens and explain what you were attempting to do that failed?


#4

Remove this:

<script src="https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js"></script>

it’s a duplicate and by calling it twice it breaks. You don’t need this when you call the bundle in your settings.


#5

Hi.

What’s been deleted is the parent pen that comprises the Tests and Run Tests buttons.


#6

please see below. I forked your pen and added back the script line and you can now test

so just make sure your pens all have the same script added to the top of each html file


#7

Hi.

I clicked on your page. I couldn’t see the Run Tests or Tests buttons on that either.


#8

you’re looking at it from the wrong view. Go back to editor view or even full page view.
All the tests are in the green hamburger icon on the top left corner.

Edit, added a screenshot


#9

Editor view:


#11

i just clicked back on your pen and I can see the hamburger menu

I have no idea at this point why your screen shot doesn’t show it.

Are you using a Chrome browser?


#12

Yes, I’m using Chrome.


#13

well that is very frustrating!
I’ve run out of ideas. Just so you can see, here’s a screen shot with your pen and the burger menu in it

Were you able to see the burger menu when you clicked on my pen or that also had the same issue for you?


#14

I can also see the menu.

it even runs the tests.


#15

No I couldn’t see the hamburger.


#16

Try the following:

Clear all Cache and Cookies. Restart and Reload the codepen.

Do the same and try an different browser.


#17

wild guess, can you check your chrome settings?
On the web browser menu click on the “Customize and control Google Chrome” and select “Settings”.
In the “Settings” section click on the “Show advanced settings…”
Under the the “Privacy” click on the “Content settings…”.
When the dialog window opens, look for the “JavaScript” section and select “Allow all sites to run JavaScript (recommended)”.
Click on the “OK” button to close it.
Close the “Settings” tab.
Click on the “Reload this page” button of the web browser to refresh the page.


#18

no, that’s not it. Codepen gives a big warning if javascript is disabled…


#19

Hi.

Your suggestion paid off. It works in Firefox. I can now see the test suite.

Thank you both!

Sean :slight_smile:


#20

It’s astounding that the suite worked for you on firefox… (or you can see it anyhow).

have you thought of uninstalling chrome completely and reinstalling? The suite is optimized for chrome so I hope you can get it working there.


#21

I uninstalled and then reinstalled Chrome and I still couldn’t see the test suite.

It looks like I’ll have to do the projects in Firefox, though I’ll still be able to use Chrome for the rest. It’s an imperfect solution but it’ll do.

Thanks for your suggestion. Thank you both.

Sean