Can't signup to Free Code Camp


Have been trying to signup to Free Code Camp today, but having been having much luck. No matter what option I choose, nothing appears to happen in the browser. I did notice the below error in the console, but not sure if it’s related.


Uncaught ReferenceError: $ is not defined <anonymous> profile email:437 login:437:5

Welcome, jdndm.

I notice you have a few browser extensions enabled. Could you try disabling them (or using the private browsing/incognito mode), and try again?

This error looks a bit like a browser extension blocking basic JS from running (being downloaded).

Hey @Sky020,

Thanks for the quick response.

I tried in both safemode firefox (all addons disabled), and a fresh install of edge. I also tried on my phone’s hotspot to eliminate my network with the same result.

Thank you, for doing that.

@raisedadead Can you see anything abnormal on the fCC side?

Hi @jdndm

Can you try an incognito window (with extensions disabled)? We did get one report of the CDN certificate having issues, but just want to rule out any extensions first.


Hey @raisedadead,

Screenshot attached of Firefox incognito in safe mode (all extensions / addons disabled).

Thanks for confirming. Looking into this.

When I get to the page with the 4 options to login options all of them are unresponsive. I can click all day and nothing happens. I’m using firefox. I’ve cleared cache etc but still nothing.

Hello there,

I have moved your post in this thread, so we can keep track of similar recent issues.

Quick update:

While we are working on this, anyone facing this could you check that the DNS is not stale? Your internet service provider maybe caching DNS, etc. resulting in corrupted/stale versions of the pages.

One way is to use a public and fast DNS resolver like, or Cloudflare’s (highly recommended):

@raisedadead, I updated my dns to use Cloudflare and flushed my DNS cache, same result.

I changed servers on my VPN and now it works.

1 Like

Oh - Yes. I forgot that if you are behind a VPN, things could be stale as well. Changing them might work as well.

I have just been able to successfully signup using github. Not sure what caused it to start working…

1 Like

Thanks for confirming folks, can either of you help us with a few screenshots of the console like before?

Since I am unable to reproduce the error in the first place, I am kind of making fixes in the dark, would love some logs to check if that worked.

Reference PRs:



So not much to show, but here’s the console now. Also I noticed that the logo in the header is now loading, it wasn’t before.

1 Like

That’s how we would like to see it. :slight_smile:

1 Like