Can't test tribute page in Responsive Web Design

Tell us what’s happening:
Describe your issue in detail here.

I’m having some difficulty trying to test my code for the responsive web design projects. I tried reading up on it and trying some suggestions through there but I was still unable to get the dropdown menu to be able to test my code. Any help would be greatly appreciated.

Thanks in advance.

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

Challenge: Build a Tribute Page

Link to the challenge:

hey welcome to the forum. I tried testing your code for tribute page from the dropdown menu. got a score of 8/10 passed. What exactly are you having difficulty with?

@cbrockman97, when you expand the hamburger menu in the upper left corner of your page, ensure you select the correct test suite from the dropdown. Then click the Run Tests button.

If a test fails, click the red button to see which test(s) are failing and text to help you correct the issue.
Be sure and read more than just the first line of the failing message. The ability to read and comprehend error messages is a skill you’ll need to acquire as a developer. Ask questions on what you don’t understand.

To be honest I never finished my projects on codepen for responsive web design and development. So I just moved on to JavaScript Data Structures and Algorithms. It still wont let me test my code. So now Im working on Front end development libraries. Still cant figure out how to get my code to test. Just keep moving forward!

I think you need to be a lot more specific about what you mean by this. We’ve all been able to successfully run the FCC tests on the tribute page you linked to above, so it seems to be working normally from our end. Do you see the green hamburger icon in the upper left corner? If so, are you able to click it and then click the ‘Run Tests’ button. If so what happens? Or maybe you are referring to some other tests? Please be as specific as possible.

1 Like

ive been on codepen several times through other system platforms and browsers. I’ve completed everything on the responsive web design except the projects because I could not get any testing to happen. (“No GREEN, RED, OR YELLOW” anything.) nothing that would appear for me in a standard js code editor I could find. I dont know the difference in what should be there to tell you what is missing. Thats all I’ve got to go on.

The hamburger icon appears on the actual tribute page, in the upper left corner, right above “Chipper Jones”.

1 Like

em k. im not really cocerned about it. Just trying to incourage the momentum to keep advancing to others

if im just the only person this has ever happened to I’m really not sure what to say.
Other than sorry. but I dont have time to bother with it anymore until the front end projects I guess. Then I’ll get them both at the same time. Cool huh!

What do you mean by this, specifically what do you mean by a “standard js code editor “. The tests need to be run on codepen forking the link. The tests don’t work on your local environment like VS Code, Sublime, etc.

@eoja, the tests do run locally if you have the CDN link placed correctly.
A lot of people place it in the head element when running locally and it will not run correctly. It needs to be placed before the closing body tag. The reason being is the tests require the HTML code be loaded first in order to run properly.
Hope that helps/clarifies.

I dont believe I said anything wrong. um lets see. Specificallythe code editor you have to use through fcc. or through your browser. depending on which browser we are using or what platform we run off of. More? ok. microsoft egde is different from chrome , safari, etc.

your right. It is distracting. I’ll share my scene with you next time.

I’m closing this thread as it’s detracted from the OP’s topic.

@parkerjmartin, if you’d like to be able to run the tests then open a topic as other have been able to run the tests without issues.

@cbrockman97, if you’re still having an issue please open a new thread describing your issue. Sorry that this went sideways.