CodePen Test Suite Graphical Issues

CodePen Test Suite Graphical Issues
0.0 0

#1

The test suite box behaves oddly almost all the time. At first, it cloned itself with a ‘default’ box after I chose my test and ran it the first time. When I tried to close to clone, it showed my chosen test suit box underneath. However, the button to open the clone overlapped the button to close the box, so I was unable to clear it from my screen to see what I was working on.

After a few page reloads (trying to get it work correctly), I just stopped choosing a test suite (to avoid cloning it) and closed the box so I could work. That worked for me.

After completing the Survey Form, I wanted to test it. I didn’t even realize that the setting buttons, and thereby the entire test suite box, had completely vanished. So I figured FCC took it down to fix it even though the was still present in my Pen. No worries.

Today, it was back and the same as before–cloning itself. The good news is that my Survey Form passed all the tests! But I hadn’t done anything to ‘beautify’ it yet, just the most basic HTML stuff. So I really wanted that box out of my way in order to make something that isn’t boring and/or ugly.

Since it passed, I figured I’d just delete the entirely as I no longer needed the test suite…

And now it works perfectly! It doesn’t clone, the X and menu icons don’t overlap anymore…but the is gone. Bizarre…

I’m not really asking for anything, except maybe an idea of what to expect from that thing in the future. I wasted quite a bit of time fiddling with it and it still doesn’t make any sense to me because I can’t see what’s going on under the hood.

EDIT: I forgot to mention that it added the line:

//# sourceURL=pen.js

to the bottom of my page when I erased the . Doesn’t seem to matter, though.