Computer BSODs seemingly randomly

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033

Additional information about the problem:
BCCode: 1000007e
BCP1: FFFFFFFFC0000005
BCP2: FFFFF880049A0BE7
BCP3: FFFFF8800978F7C8
BCP4: FFFFF8800978F030
OS Version: 6_1_7601
Service Pack: 1_0
Product: 256_1

Files that help describe the problem:
C:\Windows\Minidump\112218-24070-01.dmp
C:\Users\home\AppData\Local\Temp\WER-137842-0.sysdata.xml

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

For some reason, after I began downloading a Photoshop free trial, my computer randomly made a “shutting down” sound, and the toolbar at the bottom of the screen disappeared for a few minutes. Then it came back.

After that, I tried running a smart scan with Avast, and then I got this bluescreen crash. When the computer came back on, I tried running the scan again, and the same thing happened.

My computer has been going seemingly slower than usual lately, but this behavior didn’t start until after I tried to install Photoshop’s free trial.

I’m trying to uninstall Creative Cloud right now, but it’s not working I got this error:

Windows cannot access C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\ ElevationManager\Adobe Installer.exe

Error code: 0x80070043
The network name cannot be found.

I know this isn’t a computer tech forum, but I don’t know where else to ask this off the top of my head, and I don’t know when this thing is gonna crash again. This community is one of the smartest I’ve seen, and has a lot of people who know at least a thing or two about computer software.

I have my backup Surface computer, but its a small, buggy, fragile thing.

The OS of the computer having the problems is Windows 7.

EDIT: OK, nvm. It might just be an issue with a recent Avast Free Antivirus update, according to this other post I found elsewhere: https://forum.avast.com/index.php?topic=223430.0

BSOD problems are very irritating. It leaves you helpless and occurs loss of several vital information. if you are having BSOD error on Windows then steps given in link given below will help you fix your issue.
https://www.techsmagic.com/troubleshoot-windows-10-blue-screen-manual-steps

Thank you. I’m not having them anymore since I stopped trying to run a smart scan via Avast!, so I think it really was a faulty Avast! update that was causing it.