D3 JS: ScatterPlot

Hey, I manually calculated few dots to 7 decimals precision so it aligns with y-axis values. Calculated seconds on y-axis to y pixels and dots time to y pixels they are the same value. But the test shows values don’t align with y-axis. I really don’t know what should I do.

CodePen

Please help :pray:

Update I used yScale to set “cy” still doesn’t pass :frowning_face:

Passes all tests for me (current chrome). If you’re still having problems try a reload and hard refresh or swap browsers. I get no test failures and no errors so there’s nothing I see to help you fix.

I’ve had previous tests fail due to browser extension as well. Specifically Dark Reader for my case. Once I disabled it my test passed, check your extensions.

1 Like

I tried testing it on Edge, Mozilla and Chrome. Still passes 15/16. :face_exhaling: But now I at least know that it may not be my code. Thanks

Ok I tried it on my phone. And it passes all tests. I will investigate further after I submit it. Thanks for your help I would be stuck on this for another 6 hours trying to figure out what’s going on.

1 Like