Downloading Git to program files- i already have git bash

Hi. I just stared learing about github a few months ago, and at the time working through some tutorial i downloaded git bash and was trying it out. I tried several commands from stack overflow but i continue to get messages that list a lot of untracked files that i actually wanted to just ignore.

after a git status command i get this;

warning: could not open directory ‘Cookies/’: Permission denied
warning: could not open directory ‘Dati applicazioni/’: Permission denied
warning: could not open directory ‘Documenti/’: Permission denied
warning: could not open directory ‘Impostazioni locali/’: Permission denied
warning: could not open directory ‘Menu Avvio/’: Permission denied
warning: could not open directory ‘Modelli/’: Permission denied
warning: could not open directory ‘Recenti/’: Permission denied
warning: could not open directory ‘Risorse di rete/’: Permission denied
warning: could not open directory ‘Risorse di stampa/’: Permission denied
warning: could not open directory ‘SendTo/’: Permission denied

I want to just get out of this git desktop app and just start over, downloading the full version to my c drive.

Can i delete this and start over? or if not what can you suggest?

Nothing stopping you uninstalling and starting again

Note that there may be git repositories left over that may need deleting

Honestly git for windows is a bit more annoying than it ought to be. It ships an implementation of bash and other unix-like tools that has to work around a lot of windows’ annoying quirks to be consistent with the other OSes

I wouldn’t suggest reading stack overflow and blindly copypasting commands without understanding, I would instead suggest reading along with the official Pro Git book (free online!)

It’s very useful for understanding what’s happening, and it’s written very well in my opinion for a learner

Thank you for your response. I will do as you suggest.

Now going back I remember why I went to look for answers elsewhere. Sorry but if you call that well-written you must have a lot more technical knowledge than me and you can no longer see that it is not clear or well-written.

Take for examle this, which would be the answer to my question and the reason I have had so many problems. I do have administrator privleges and I want to configure my repository so the first step is ;

/etc/gitconfig file: Contains values applied to every user on the system and all their repositories. If you pass the option --system to git config , it reads and writes from this file specifically. (Because this is a system configuration file, you would need administrative or superuser privilege to make changes to it.)

What is the command I need to use if I have administrative privilege then? How do you pass the option"–system" to “–git config”? What the reader needs to know here is specifically what is the command. It is very frustrating indeed and makes a person want to use a bunch of bad names to descibe the people wrote it , seemingly wihout ever having a noobie test it out.

Sorry for the slow reply

Getting administrator or superuser privilege depends on your operating system

In a unix-like environment it’s often done with sudo or su

In a command line environment to pass options to a command you type them in addition to the command, as an example:

git show --pretty=full

I suspect the bit you’re missing before the book is command line experience, which in Windows would be cmd and in unix-like operating systems would most likely be bash

Git comes with bash so it might be worth looking up about those first

As an alternative, though I wouldn’t personally recommend it, there are graphical git clients like tortoiseGit for Windows which abstracts away most of the command line tasks

I am sorry i got into this. Now everything is messed up. I actually got so far as to using github desktop back in July and I made a commmit. Now I have wasted weeks and I am just sitting here crying, YES crying, with the same error message.

I can not get away from it because it even comes up in my VSCode projects
The git repository at ‘c:\Users\Lorenzo’ has too many active changes, only a subset of Git features will be enabled.

I have been getting ill over this. Everyone points me to tutorials or claims I will find everything I need by google searching. I could go crazy like this.

So now what to do? Since nothing is working what do I do? Pay someone to help me? How do I find such a person? Can someone suggest a tech support service or something?

I still suspect you initialised a git repo on your main user folder rather than just an individual project.

For example, let’s say I have a Jackson folder (I do), and also a dev folder (also true) and then lots of folders in dev, one per project.

.... /Jackson
........ /Documents
........ /Downloads
........ /Desktop
........ /Dev
............ /fcc-tribute-page           <-- git init this
............ /fcc-portfolio-project    <-- git init this

I could theoretically track changes across all my files on my computer by running git init in my Jackson folder, but that is asking git to do too much. Similarly, I could just track code by git initialising just the dev folder, but eventually that gets to be too big too.

I only git init in each project folder. That should get rid of the error message you’re talking about, unless I’ve misunderstood the issue (which happens a lot).

Also, when opening projects in VS code, open them at the project folder level, so you only see the files relevant to the project, not the whole file system.

Thank you again Jackson. I think what I am going to do now is to go back to working on projects as I go through freecodecamp lessons for about a week. For now I will open just the project at the folder level. For my sanity I need to make some progress. So instead of working on this git .ignore, I will ignore git altogether. I do not even really even have any concrete reason to be using Github for now. I just wanted to begin using this resource as soon as possible. At this point it is making me lose confidence and making me really angry. I also have to mention that I am using an Italian keyboard and the tilde does not exist. I have to use alt 126 to make the symbol ~. It was several hours just to get to that point. Now I am wondering if other commands I am using are not working because they are named differently in italian. For example user is called “utente”.

So I will move forward with Javascript on freecodecamp. Then with a little bit of success under my belt i am going to get back into it and learn not just what I need for now, but really understand. I want to document my experience for other italian language users so that all this will not have been in vain.

I will be back. Thank you again.

1 Like

Sorry the video didn’t help, I had a similar problem and following him step by step helped me fix it.