Gitpod and coderoad

I restarted the Gitpod workspace for going through Learn Bash Scripting by Building Five Programs. My files, those I have created are there but CodeRoad:Start wants to start from the beginning.
Since this is the second time it has happened, to me, I need to understand why is happening and maybe find a solution for it.
I never logout from freecodecamp before closing the workspace and stopping it. Why do I have to start from the beginning again. Is there a way to start in CodeRoad:Start from where I left it?
As I said, all the work is still there, as far as I can tell.

Thank you

2 Likes

Hi, @wizardinaction , welcome to the FCC forum!

Every time you click on start new project a new VM is ran, therefore a new project is opened.

Try clicking on ''your Gitpod dashboard" link:

image

It should lead you to a screen where your projects are located. From there you can open the one you want it and continue from where you stop.

There is another post of a fellow who was experiencing the same issue:

1 Like

Thank you for the response @wilsond_barbosa and the welcome message. However, your suggestion of clicking the Gitpod dashboard link instead of the Gitpod workspaces link is not applicable here, since that’s what I have been doing. I click the Gitpod dashboard where I find my previous workspace. I ask it, then, to open the workspace. The environment appears as I left it, with all the files as I wrote them, however the CodeRoad is not open. I use the instructions to reopen the CodeRoad:Start and that’s when I see that it wants to start from the beginning again, ignoring the steps I took before. I was very close to finish 79% done.
I would like to know if there’s something I am missing and doing wrong. Where’s the progress from the perspective of CodeRoad saved?

Maybe I should mention as well, if it helps, that this is not always the case. I have stopped the workspace several times before, and when I go into it as I described previously, the document for CodeRoad is there, opened and beckoning me to continue from where I left it.

Thank you.

1 Like

Oh, I see!

From what I understand, the files are loaded properly, but you are having issue opening the CoadRoad, right?

When you enter CodeRoad: Start on view → palette it should open CodeRoad from the step you finished. Could you send a screenshot of what happens after you execute the command?

Also, by any chance, did you selected the right workshop? I’m asking you because I have the like, 3 different workshops of the same project and, sometimes, I’ve opened the wrong one.

Not quite. I can open CoadRoad but then, it wants me to start from the beginning instead that from where I left it the progress.

The workspace is the correct one, previously used to go through the exercise, it is NOT a new instance or another instance.

Is there a way to start coderoad from a point in time?
Thank you

1 Like

That’s really strange! Because with me, when I open the workshop and run the CodeRoad: Start it loads the CodeRoad at the step I left it, not from the beginning.

I did this with 2 projects, Learn SQL by Building a Student Database: Part 1 and 2.

Say, how many changes are registered on your workshop? Could send a screenshot of it, please? The screen I’m referring to is this:

I tried, in the previous , to post several snapshots sequence, but it complains that I am not allowed since I am new. :wink:

I just started another brand new instance of Gitpod workspace after I checked that the original one was properly stopped.
In this new instance I performed the first two tasks and they passed the test. I proceeded to stop the work and stop the container. I logged out from freecodecamp and I closed my Firefox browser. I started Firefox, logged into freecodecamp, I went to the link that says Gitpod dashboard, started this new workspace and the coderoad wasn’t loaded. I loaded as per the instructions and CodeRoad wants to start again testing from the beginner. I lost the progress again.
That means I cannot start a course I cannot finish before I need to close the browser. That is not going to work for me.

Thank you.

don’t do this, once you log out from freeCodeCamp the VM is not linked anymore and even if you finish the project it’s not going to be counted. Please do not log out from freeCodeCamp

Now, I am very confused. Are you saying I can never log out from freeCodeCamp even if I am done for the day, if I have not finished the course? Are we expected to go through a course in one setting?

You can close your browser and everything, just do not log out of freeCodeCamp. there is a red banner saying that in all the project pages of this certification. If you want the technical explanation, logging out invalidates the token that is linking the gitpod virtual machine to your freeCodeCamp account, so logging out means you can’t use that virtual machine to complete the project on freeCodeCamp

I appreciated the clarification @ilenia . However, I have to say that the “red” message could be a little bit more precise. It could be understood as if you log out of freecodecamp the work you are doing on the course will not be saved. Instead what you are saying is that it stands for: “If you log out of freecodecamp you are FORFEITING your work and progress and you’ll need to start anew”. Also, there’s another assumption as well about closing the browser and everything will be fine since closing the browser might log you out if it is set to clear data when closed.

I don’t know about cleaning data, as it’s specifically signing out that delete the token… You can follow progress on this issue following this github issue Create guide for adding token to Gitpod after logging out of FCC · Issue #53630 · freeCodeCamp/freeCodeCamp · GitHub

I might be late on the ball here but i was having the exact same problem. I was switching between computers and when i wanted to resume my progress the CodeRoad:Start started from the beginning. But i just had to keep pressing ctrl+enter without actually doing any of the steps untill it reached the level where i left off. Maybe not the best solution and a bit time consuming, but at least i didnt have to redo all the levels! Hope it works for you to!

2 Likes

Hello @tyvret and welcome to the forum. Thank you for stopping-by and contributing.
That might succeed sometimes, much depending of the course and the history recorded from the terminal and if “all the stars are aligned in the sky”.

I had the exact same problem today.

I logged into fCC, github and gitpod on a different computer today because I wanted to continue the Learn Git by Building an SQL Reference Object course out of the house while I had some time to kill.

To summarize

  • Logged in on a new laptop (which I don’t normally use for fCC)
  • All of the work was present, but CodeRoad presented the information for Step 1
  • However, if I typed in “echo hello” for step 1 I got the error for the real step I was on
  • So CodeRoad presented instructions for step 1 but was awaiting input for Step 70%
  • Wow
  • When I logged back in on my usual computer, it’s the opposite, it presents instructions for the step I’m on, but will show an error waiting for Step #2
  • I clicked “Reset” and it finally worked properly (on the original computer only)

This does suggest there might be some browser token that affects CodeRoad. Otherwise there must be a config file that CodeRoad uses to keep track of the step? Which must be updated to get to the correct step.

This fix has been giving me better performance when I don’t switch computers:

Lot sync again with Coderoad. Cannot get Coderoad and my project to sync back up. Reset doesn’t work. No idea what to do to fix it now. Maybe it will magically work later.