I cant get my VScode live server to load my codes

Hi, I’m new to Vscode and I have been battling with Live server for days now. Anytime I click on ‘Go Live’ it will be displaying Port:5500.

I’m so frustrated right, VScode is great, makes my job easy. But the Live Server is not letting me enjoy it.

Below is a picture,

P:S- I have google and google and google

vsccodee

Welcome, Devbayo.

You have not actually explained what the issue is. Are you not wanting Live Server to make use of port 5500? Is port 5500 not loading any content?

Thank you Sky020.

Port 5500 is not displaying my html contents on chrome. I have installed Live Server extention on chrome, i still cant get it to display or open my chrome

Well, let us debug:

  1. After opening port 5500 in Chrome, what can you see in the console?
  2. Try changing the settings, and default port to 3000: liveServer.settings.port: 3000 (this is done in your settings.json file for VS Code)
  3. Try explicitly setting Live Server to open Chrome:
    liveServer.settings.CustomBrowser: "chrome"

Try one of these at a time…

Thank you alot sky020, sadly I still can’t get it to work. unfortunately I have uninstalled vscode. I will continue with other text editors. I really appreciate your efforts.

I am sorry about the bugs…that is the life of a developer. Just by the way, I have always used live-server. Originally, I used it with Atom, but now I use it solely with VS Code. I never had any issues with it.

To run it up: Open a terminal in the project directory:

live-server .

Has never failed me.

1 Like

This is exactly what I’ve been going through for the past two days now and it’s so frustrating especially as a beginner; but it’s also the time to learn and build the fundamental habit of debugging and proffering solutions to problems. :man_technologist:t6:

Hi, I have solved the bug, I upgraded my OS to windows 10. Vscode is working fine