I can't see what i'm coding

Hi everyone, im having this problem with the output of the code editor that the background is always white, and this don’t let me see what I’m doing. This of course can be solved by changing the background color in the <style.> part of the code editor, but i don’t think it was mean to be this way. This started to happen in the html part of the course and since then never stoped and it happen in every single challenge. Attached pictures so you can understand. (sorry for my English, im from Argentina)

Maybe the problem is my web browser? Idk, I have only try it in firefox.

Welcome there,

We recommend disabling all browser extensions with access to freecodecamp.org as they can affect your experience throughout the curriculum.

Hope this helps

Hi! Thanks for taking the time to answer. My only extension is adBlock and is disble for this page. Maybe is another thing?

Are you saying the color of the output text is white? Are you sure you didn’t customize something to get it that way?

I just tested it in the latest version of Firefox ESR on Windows and it worked just fine. But have you tried in a different browser? If it happens in all browsers I would assume that it is some system color setting doing it. What OS are you using?

Hi! Thanks for taking the time to answer. Yes i’m sure, i didn’t change anything. The problem is that the background is white and the text too, and just appeared that way every time i reload the page.
I’m using Debian right now, i think is really weird if that’s the problem.

Does the problem happen in different browsers?

There are absolutely no color styles being applied to any element for the challenge you posted the image of. I don’t see how the text color can be white unless it was changed in the browser or the system. The browser default text color is black, it has to be overwritten by something (default styles, CSS applied to the page, or possibly system font colors).

Maybe try a non-dark theme for the OS and see what happens, although I would think that it would have been a problem from the start if that was the case and you didn’t switch themes at one point.

You can also try clearing the browser cache, but I don’t really see why that would help but you never know. Also, do try a different browser as well.


Edit: You can also try inspecting the page and looking at the styles being applied to the elements. Right-click the output and select Inspect.

1 Like

i don’t really know what other browser i can use in linux

You have a few options on Debian:
https://wiki.debian.org/WebBrowsers

1 Like

I have try everything that you suggested and doesn’t work, it keep the same.

Oh wow, you’ve got a ton to choose from:

Firefox
Chrome
Chromium
MS Edge
Brave
Vivaldi
Opera

If you can’t install them through the package manager you can just download them directly and install them from tar.gz.

I agree with @bbsmooth . You could choose one of the following browsers. And try not to use incognito mode or any ad blockers while coding. If that does not work as well, click “reset code”. This is what I usually do if something is wrong with the code or if I have a display issue and it always works.