Learn How JavaScript Assertions Work Error

Again, the second error is with the correct solution and live app URL.

My Replit project is here: boilerplate-mochachai - Replit

And the solution URL is: https://boilerplate-mochachai.elohimcampo.repl.co

Thank you in advance for the help,
Elohim Campo

You you please provide a link to the challenge? You always need to provide a link to the challenge, so we know exactly which one to reference.

Your solution url is not working. When you clicked Run, did you see any errors in the Node console?

You could try to fork your repo and then click Run on the new one. Sometimes that fixes these kinds of issues.

Sorry, the link to the lesson is: https://www.freecodecamp.org/learn/quality-assurance/quality-assurance-and-testing-with-chai/learn-how-javascript-assertions-work

I forked it, ran it and the console shows my basic assertions #isNull #isNotNull succeeded without mistakes. Except the rest of the code which is normal cause is not completed.

It looks like the repl project files from the link provided by FCC on the lesson https://www.freecodecamp.org/learn/quality-assurance/quality-assurance-and-testing-with-chai/learn-how-javascript-assertions-work are incomplete. If you check this other project boilerplate-mochachai - Replit from another user there are more files. Can you @RandellDawson talk to the FCC team to sort it out?

Not sure what you are talking about. They both appear to have the same number of files. Can you show us which files are in one and not the other?

Sorry @RandellDawson it is not missing files, in the repl app is showing 13 files but in the browser is showing more. So that shouldn’t be the problem for now.

The reason I saw more files on repl on the browser was that repl was importing the project as a python project so that it was wrong. Anyway what is wrong with the project and the live app URL?..

I thought you said in the reply to my 2nd to last reply that everything worked once you forked it. So, why are you asking me what is wrong now?

The #1 basic assertions from the console pass the test, but the FCC test don’t, the FCC test fails and shows up:

// running tests
All tests should pass.
You should choose the correct method for the first assertion - isNull vs. isNotNull.

You should choose the correct method for the second assertion -isNull vs.isNotNull

. // tests completed !

Can you confirm the replit project link you are submitting now?

Repl live app URL is still not working. I switched to Glitch and it’s working perfectly. So, thank you anyway.

Glad to hear you were able to get something working.

1 Like