Link not working to test my projects

You can build your project by forking this CodePen pen. Or you can use this CDN link to run the tests in any environment you like:
I’ve tried Opera, Chorme, and Firefox.

1 Like

Try this one

1 Like

Thanks I got it. I had to use the first link form the tribute page, the other ones are broke.

1 Like

So it turns out that is also not working. It shows the test, and seems to allow me to run the tests, but the results don’t actually have any info in them. It should be listing all the test points and why you pass or fail them.
Even the fork on codepen is broken in this way.

Thank you - that worked! :slight_smile:

Although it is giving a “mocha not loaded” error from line 271… I have a screenshot but don’t know how to upload it

just drag and drop your img screenshot in here

Do you have a link to your project (i.e. Codepen or JSFiddle) you could post?

Mocha error:

Test feedback error: (this is what I get if I fork on Codepen as well)

Link to my project (same issue as when using Codepen):

Previous project used this CDN copied from project criteria:

It was working perfectly last week, but now the test suite does not even show up:

I think your id #nav-bar is in your ul list it should be in yo

But this is your error

  1. Within the element I can see a element with corresponding id=“nav-bar”.’ AssertionError: The #nav-bar element is not a element : expected ‘UL’ to equal ‘NAV’
    at Function.assert.strictEqual (
    at n. (
    at r (
    at (
    at i.runTest (
    at r (
    at n (

put your id=“nar-bar” in your nav

Thank you, I appreciate your input regarding my site. However, that does not solve the issue of the test suite being broken. I have tweeted FreeCodeCamp so hopefully the test suite will be fixed soon.

1 Like

You should be using the following test scripts link for all of your projects.


I tried that link, and was getting the errors described above.
Today the errors appear to have been fixed, and within the last hour the layout issues on the feedback have also been fixed so they are no longer disappearing offscreen.
Thank you. :slight_smile:

1 Like

works just fine :wink: thx