"Oops" Error - Help Please

Hi all,
I have a very odd issue (to me).

I am able to log into my FCC account and view the Forum BUT,
when I try to “Visit Curriculum” and attempt to sign in to track of my progress I get the error:

“Oops! Something went wrong. Please try again in a moment.” , In a banner on the top of the web page. I cannot keep my progress for my courses.

I am running Xubuntu 18.04 and have tried several things:

  1. Opened acct with Firefox and Chrome,
  2. Tried to open acct using my email acct & Github and Google acct.

Getting to “Learn” has some problems.

Thank You,

I removed your email address because this is a public forum.

Try clearing you browser’s storage, refreshing the page, and logging in. Sometimes weird artifacts get into your browser cache.

If that doesn’t work, you may have accidentally created a duplicate account when you attempted to login with multiple methods. If that’s what happened, you need to contact support@freecodecamp.org and ask someone to manually go looking for your accounts.

Thanks for removing email, I knew that was stupid…

No worries. We’ve got your back.

You know I still cannot make FCC save my results for my curriculum. I am still getting this exasperating message.

Have you sent that email? at this point seems you really need to

Did you try both of

  1. Clearing your browser’s storage, refreshing the page, and logging in
  2. Contacting support

I cleared Every thing out of Firefox except my passwords and I am working on ressetting my own password. hold on…

I had to reset the password myself.

Is everything working alright now?