Problem with backslash database course

Hello sorry by disturb you I am having problems with the backslash here in relational database I was trying to write it many times but it was not possible \ i dont know what happen because i can write \\\ every time that i want the problem is in pgsql console sincerely I offer you apologies by my orthography i am not full english.

I tried with mozila,chromme,safari and others it is not problem with my browser,i worked on codeally platform.

Gabriel Contreras

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.64 Safari/537.36

Challenge: Build a Mario Database

Link to the challenge:

Hi! Can you confirm if \ is working outside of Postgres? And, what are you trying to achieve with \, I can check for any other workaround if available.

For example, there are two ways to exit the Postgres terminal: \q and Ctrl+D. So you can use the 2nd method to exit in case \ doesn’t work.

Lastly, also check the input language in your OS settings. They should be consistent with your keyboard layout.

I had the same problem I’m using mac as well. The problem is that the virtual machine doesn’t allow you to use any key combo to use backslash, like pressing control, shift or option. The solution i found is changing keyboard, in may case I’m using right now British-PC keyboard in order to get backslash using the key that is at the left of the Z key, without a combo of keys. I can guess by your name that you where using Spanish keyboard like me. It may be hard at the beginning to learn where all the symbols are but after a while you get used to. For me is very help full to keep the keyboard viewer (like the one on the picture) to remind me where all the new keys are


1 Like

Same problem here. I’m using MacBook Air M1 2020 with Spanish keyboard and I normally write '' using Opt+key under escape, but the console somehow doesn’t type anything using Opt+… I tried using copy+paste but It doesn’t allow it despite I already gave permissions on Chrome so I dont know what to do.

Switch to using an English United States language keyboard and the backslash will work.

Just an FYI, this is still an issue, and a quite annoying one I’d say.

Yes, switching to US keyboard works, but to keep switching keyboards to be able to complete an online training is cumbersome at best when you don’t know the keyboard layout by heart and end up having to switch each time you need the backslash, and then switch back.

In general the codeally-thing is quite cool, but it’s highly unstable both for starting it, and for using it.

Unfortunately this has nothing to do with fCC or codeally. The programming language itself is the one that needs that specific symbol from the English keyboard.

You can open up an onscreen keyboard and keep the language on English all the time when working or you can copy the character into a file somewhere and recopy it as needed.