Problem with Glitch links for ALL back-end projects

Just in case anyone here knows who to contact/inform, the glitch projects meant as starter projects that have links in all the challenges/projects after the data-visualization section are not working properly.

1 Like

Such a vague statement.

I’m not sure how else to phrase it.

Maybe this is better. If I follow the glitch link on this challenge–as well as for all the other challenges including a glitch link–the glitch project that is linked does not work properly. When I follow the link, the project doesn’t fully load and I get the message, “Arg, something went wrong. Try again?”

https://learn.freecodecamp.org/information-security-and-quality-assurance/information-security-with-helmetjs/understand-bcrypt-hashes/

1 Like

In the glitch, click on the ‘logs’ on the left column, are you getting an error message in the logs? I am, because the computer I’m using (a public terminal, at a local employment office) blocks the jQuery that glitch is loading. And that error is what’s popping up that ‘Arg’ message, at least in my case.

Thanks for the response!

There are no errors that show in the log but if I view the files client.js, style.css, and server.js files…there is nothing in them but the text:

This document has been deleted outside of the editor.

Please run “refresh” in the console.

Well I can’t get the thing working so I agree that this challenge is not user friendly enough.
Not sure if that is by design?
I don’t even know what this is teaching you apart from some sort of encryption?

Well, I never stated that the challenge wasn’t user friendly.

The problem is that it (the glitch project template) isn’t loading as it should.

I’ve already completed the assignment so I know that it HAS worked. Upon returning to it a second time, however, the linked-glitch project is “broken”.

Thanks for taking the time to respond either way.

I have singed in to Glitch via GitHub and prolem was solved.

So you just sign in using GitHub and you are good to go.

Thanks for the heads-up! Someone on GitHub mentioned success via the same route you mention. It probably doesn’t matter so much if the goal is to complete the assignments but I was able to use the glitch templates without signing in before.