Stuck on Starting virtual server

Hi there, I was running the first project on the database certifications and, after two days of it working now I’m stuck on the “Starting virtual server” step.

I’ve reloaded the page multiple times, opened another tab without closing the first one and none of them worked. I’ve tried opening another project and also nothing. The issue is persisting for like, a day now.

Could someone help me with this issue?

2 Likes

This has happened to me periodically working through these projects, and now I’ve been stuck on this step for a few days trying to do " Learn Advanced Bash by Building a Kitty Ipsum Translator"

It seems to be more persistent now, before it seemed to clear itself in a few hours or a day.

If I go to the codeally website, it used to have a section where it hosted coding projects, but I can no longer find that. It seems to be pivoting into a job search website? I’m only able to find that going through my history:

https://app.codeally.io/app/code

I can’t run it there either. Is it possible they discontinued support?

CodeAlly is still enabled in github OAuth (https://github.com/settings/applications

1 Like

I’m having the same issue :confused:

Same here, folks. It was working yesterday. :frowning:
However, upon checking the Firefox console, it seems there might be an issue with the Codeally API.

1 Like

Zero contact info to be found on the site. WHOIS on the domain also has zero contact info.

It just seems like a job search site.

I’ve emailed the contact I found here: https://www.crunchbase.com/organization/codeally

https://techcrunch.com/startup-battlefield/company/codeally/

HI, CodeAlly

Great news! It’s now working! Let’s finish the course!" :slight_smile:

I was also able to get in just now!

Now I just need to restart CodeRoad a few times… it worked!

Good luck everyone! :+1:

1 Like

Nice! Mine is working as well now! Thanks for all the help guys, good to you all!

Mine was back,

Today however it logs me into the server but my project is gone, all files are gone and coderoad is not installed

https://www.freecodecamp.org/news/how-to-run-freecodecamps-relational-databases-curriculum-using-docker-vscode-and-coderoad

I’m going to try continuing locally using this, CodeAlly is just far too unreliable at this point.

Is it possible to submit solutions on the website and complete the section if we do this locally? Does not seem like it, unfortunately.

That’s strange, mine is working and I all the work I have done is still there. The thing is that you can’t earn the certificate if you run them locally, unfortunately. I dont know how to help you, but maybe you can try restart the VM? But if you do that all the progress will be lost and you’ll have to start the project from the beginning.

I don’t want to sound ungrateful, because everything here is free and all, but sometimes this certificate can get on my nerves, as you said, codeally can be very unreliable :frowning:

I tried to follow the steps to reset the vm, but now I get this error and it tries to load this invalid URL.

Screenshot 2024-01-27 173512

Giving up and running it locally and I will try to follow this advice on how to complete on FCC:
https://forum.freecodecamp.org/t/local-database-cert-code-to-fcc/641820/3

Were you able to resolve your issue?

Mine is stuck at Starting virtual server again. I assume this will be a constant on this certification, but it’s ok! We’ll get through it.

Hey @pkdvalis - how did you find running it locally?

I haven’t tried it yet. When it really stopped working I just moved ahead to the “Back End Development and APIs” curriculum to not waste any more time.

I’ll circle back on this.

I gave it a go and did the Celestial Bodies Database just fine. I’ve saved the dumped .sql file to my pc for when CodeAlly is back up and running.

I did initially move ahead myself to the course you mentioned but I do enjoy working on one thing at a time, so hopefully I’ll just continue like this for now. It’s not ideal, but at least I’m getting fingers on the keyboard.

Update: I was able to rebuild my database locally with the following steps.

  • Closed my locally running VM with my completed database and CodeRoad tutorial
  • Restarted VSCode following the steps on the guide run the relational databases locally
  • Copied my universe.sql file from my local machine to the VM project workspace
  • Entered in to terminal: psql --username=freecodecamp --dbname=postgres < universe.sql
  • Logged in again to psql

My database was successfully rebuilt and passes the tests. Now to wait for CodeAlly to be up and running again and check if this works to pass the project.

1 Like

Same here. Stuck on that darn screen for a couple of days. Then it worked for a day or two. Today, I haven’t been able to access at all.

I’m trying to run the course locally on my computer, but getting that darn Docker to even run was a struggle. I started trying to run everything on my computer hours ago and have not yet been able to run a single lesson. What a nightmare
(sorry for the venting, it’s just been one of those days in which nothing works, and for no apparent reason

For that project, you just need to upload universe.sql to a github repo and submit that link!

1 Like

Any specific errors getting Docker to run? What was the problem?