Test buttons not working on challenges

Test buttons not working on challenges
0

#1

I’m working through the es6 section, and so far I have not been able to pass the challenges because the test button won’t work. I reload the page, I reset the code, but every time I click on it nothing happens. Anyone else have this happen? Kind of annoying


#2

Are you by any chance using Edge, IE, or Safari as your browser? Free Code Camp has been updated to use newer technologies. It makes the application much faster and it means that we can go much longer without having to do a huge migration like the recent one. However, Edge, Internet Explorer, and Safari are very bad about choosing not to adhere to standards and support new functionality in JS and CSS. Right now, that means that these browsers exhibit lots of unexpected behavior. If you become a web developer you will come to hate these browsers with every fiber of your being.


#3

I’m using chrome. Got to make use of those developer tools


#4

If you’re on the most recent version of Chrome, I believe that the ES6 challenges should be working. Could you include your (formatted) code and a link to the challenge that it relates to?


#5

The earlier es6 challenges worked fine, but this is the most recent one im on, and the 3 or so behind this challenge did the same thing

So my code is

const source = [1,2,3,4,5,6,7,8,9,10];
function removeFirstTwo(list) {
  "use strict";
  // change code below this line
  const [a,b, ...arr] = list;
  // change code above this line
  return arr;
}
const arr = removeFirstTwo(source);
console.log(arr); // should be [3,4,5,6,7,8,9,10]
console.log(source); // should be [1,2,3,4,5,6,7,8,9,10];

and the link. Nothing comes up when I run it
challenge


#6

Double check that you have an updated version of Chrome and that you aren’t running any extensions which might block script execution. When I put your solution into that challenge, it passes normally.


#7

I am also having trouble with the test buttons. I am in the “Basic JavaScript: Increment a Number with JavaScript” and it won’t run any tests. I’m in an updated version of Chrome. I was going through the lessons easily and then it just stopped and I haven’t been able to progress.


#8

Have they started working? I checked all my settings and it all looks fine. I just waited for a few hours, and it finally worked. At least just the one i tried.


#9

I just tried and it’s still not working. This will be the third day for me. :frowning:


#10

The significant majority of people who think the tests aren’t running are actually just failing the tests. Can you include your (formatted) code and a link to the challenge you’re stuck on?


#11

https://learn.freecodecamp.org/javascript-algorithms-and-data-structures/basic-javascript/increment-a-number-with-javascript


#12

Your solution is incorrect would cause errors. What is i in your code?


#13

I don’t know what changed, but I changed a line and I’m starting to get error messages. Before, nothing was showing no matter what I did, it only displayed “Your test output will go here.”


#14

i think your code should be syntactically correct so that tests can run !