Tribute page, I click "I've completed this challenge" and nothing happens

I have completed the test on codepen and passed all 10 tests for the tribute page. When I copy the URL address and paste to “solution link” and click “I’ve completed this challenge”. Nothing happens. How do I fix this? I have tried on three different browsers and the same issue is happening?

I have tried other challenges, completed and passed the test and the same thing is happening

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.190 Safari/537.36.

Challenge: Build a Tribute Page

Link to the challenge:

Hi @aaronpak93 !

Welcome to the forum!

We can better assist you if you can elaborate on what you mean here

Also, it would help to see the url you are trying to submit for the project.

If your url looks like this
https://codepen.io/freeCodeCamp/pen/MJjpwO
Then that means you haven’t forked the project properly.
The fork option is located at the bottom right hand corner of codepen.
Click on that and make sure the url changes to your username not freecodecamp’s.
Then save the project.

I have got it sorted now thanks. I had to make an account on codepin then “fork” the page before copying the URL