Unable to obtain my certifications

Hello, everyone!

I have been a student for more than three years now, but I did not follow the courses assiduously. But since the last complete update of FreeCodeCamp with a more complete and consistent curriculum, I have become an avid student. Thanks to the developers and teachers of this platform!

However, for almost a year now, I’ve been frustrated because FreeCodeCamp no longer saves my learning progress. If you go to my profile page (https://www.freecodecamp.org/ekoulemaneng), you will see that I don’t have an bio, only 264 points and no certification. And yet, when I use my favorite browser, my profile page displays a small bio and the three certifications I have already obtained.

In fact, when I say that I have obtained these certifications, it is not quite true. When I click on the “Show certification” button in my settings page or on the “View XYZ Certification” button, a yellow banner appears with the message: “Looks like user ekoulemaneng is not Responsive Web Design certified”. And yet, I checked several times that I had done all the exercises, completed all the projects and accepted the Academic Honesty Policy and claimed certicicates.

I don’t know what to do anymore. Please, help me! Thank you.

Check your privacy settings. You may have something set to Private that is required to show certificates.

I just checked my privacy settings again. I have also set up so that all my information is displayed publicly. But nothing has been done: the problem has still not been solved.
Is it possible that my browser is not communicating properly with your database server? I feel like everything is cached in my browser, including my configuration settings…

I just looked at the profile you linked. It looks like you haven’t done anything on that profile since 2016. Is it possible that you accidentally created a second account?

Here are some screenshots to help you realize that I am not mistaken.

Like I said, your public profile shows that you have not done FCC challenges since 2016.


As I suspected, that is not what I see when I go to the profile that you linked in your original post.
https://www.freecodecamp.org/ekoulemaneng shows the following:

Notice the url of the address bar. It is indeed “https://www.freecodecamp.org/ekoulemaneng”.

Thank you for your gracious dedication, but I feel that you absolutely want me to be wrong. You refuse to consider the possibility that the issue is coming from your system.
Well, you should know that I have been seeing this issue for several months. But I had refrained from reporting it until I had considered all the possibilities of which I would be the cause.

I’m trying to help you figure out what is going on. I’m just a volunteer who helps on the forum. I’m not refusing to consider anything. The only thing I know is that when I go to the link you provide I don’t see the profile that you have in screenshots.

Very often when someone is having trouble with their certificates it is caused by something small and easy to overlook, like forgetting to click the “claim your certificate” button, having privacy settings that hide their data, or not knowing they have two accounts.

Ok. Excuse me.
I even downloaded from my settings page and carefully examined my data in json format. This file clearly shows that I have obtained 3 certifications.
I had had a problem with desynchronization when I resumed my studies on FreeCodeCamp after several months of absence. I had noticed that a number of exercises I had solved were still considered unsolved.
I had to start again but I noticed after several months this desynchronization between what my computer and my favorite browser were displaying and what another computer was displaying when I opened my FreeCodeCamp session.

One last thing to try: Could you change your username and then try looking at your certificates?

1 Like

Thank you so much! I changed my username and it worked! I’m sorry I was rude to you. Thank you and have a good day.
Here is the new url of my profile page: https://www.freecodecamp.org/ekoulemanengck

Yay! It shouldn’t be possible, but I think that somehow you ended up with two accounts that had the same username. Thanks for your patience, and congratulations on your certificates!