Visual Studio Code Consumpt high CPU while typing

Now I start next.js project my CPU use 30-40% only if I typing in Visual Studio Code
I think it is not normal.

(I’ve been using it for a while but not notice this happening
but I do only pure Html/CSS/Javascript projects.)

I use Computer i7- 8gen, 32GB DDR4, SSD, Win 10
Not run dev environment
I not use extension or only prettier but both have same result.
I reinstall my Vs Code and also clear cahce from AppData
I try 1-55-2 and 1-53.2 version also and of course 1.59.0

It is normal? What’s happenig? How can I optimize VS code consumption?
What are your suggestions?

I don’t have a specific answer for you but have you tried googling for answers? I did and a lot of them seem to recommend you start disabling extensions until you find the one that is causing the high cpu usage. I’m not saying that is your problem, but it’s probably worth exploring.

2 Likes

I don’t think it’s normal.

I personally watched two videos titled windows 10 high disk usage and windows 10 high memory usage and did what they said like disabling auto indexing/search and all and now even after installing a dozen extensions also it runs very smoothly.

1 Like

https://github.com/microsoft/vscode/issues/112315

https://github.com/Microsoft/vscode/issues/7741

https://stackoverflow.com/questions/51886037/visual-studio-code-using-large-amounts-of-cpu

Similar to your description.

1 Like

I exploring very lot of. I described that I reinstalled severel times vs code as final resolution. and clear Vs code cahce also. so no extension and then same result…

Thank you. I yet very lot of video such video saw and not run file indexing on my windows 10. My Disk and my memory is excelent state while i typing.

Only CPU usage high and only if I tying on Vs code.
In other program typing isn’t CPU high usage

I delete Vs code and install updated version 1.59
I clear cache from \AppData\Roaming\Code
so no extension.
any extension.

Do you have any suggestion? I try everything yet that suppose. Please write again if I misunderstood something.

Thank you very much.
I saw and did step by step

suggested this:
This had suppose open new smaller file >> I try not help
The solution was an extension disabled >> I have no extension.

suggested this:

Change settings.json

{
"git.enabled" : false,
"update.channel": "none",
"telemetry.enableTelemetry": false,
"telemetry.enableCrashReporter": false,
"files.exclude": {
"**/largeFolder": true
}

Not help

suggested this:

Change settings.json

{
"files.exclude": {
        "**/tmp/**": true,
        "**/node_modules/**": true,
        "**/.git/objects/**": true,
},
"files.watcherExclude": {
        "**/.git/objects/**": true,
        "**/.git/subtree-cache/**": true,
        "**/node_modules/**": true,
        "**/tmp/**": true,
        "**/dist/**": true
},
"search.exclude": {
        "**/node_modules/**": true,
        "**/dist/**": true,
        "**/tmp/**": true,
        "**/.git/objects/**": true,
        "**/.git/subtree-cache/**": true
},
"extensions.autoCheckUpdates": false,
"extensions.autoUpdate": false,
"search.followSymlinks": false
}

Not help

suggested this:
Disable Microsoft Live Share extension >> I have no extension

Do you have any suggestion? idea?

Thank you again.

I send message as report issue from Vs code:
send to Github

Github:
Hi, unfortunately this issue has no reproducible steps and there is nothing that we can do.
I suggest that you just open a question on stack overflow and the community there will be able to help.

Stackowerflow:
We don’t allow questions about general computing hardware and software on Stack Overflow.
You can edit the question so it’s on-topic for Stack Overflow or post a new one on Super User.

I will try Superuser but not surprising if send to Github :slight_smile:

On my laptop there are two GPUs, an embedded one from Intel and a discrete one from Nvidia. There is a bios option called “Hybrid Graphics” mode that allows the system to dynamically use the embedded one when there are no high-demand GPU intensive programs running. Disabling this hybrid graphics mode has made VSC very responsive and fast.

From one of the threads, you may have missed it.

1 Like

I have only one Integrated one: Intel(R) UHD Graphics 630

Do you think disable “Hybrid Graphics” mode will use?

Otherwise I reinstall windows but same the situation.

I put my question on Super User. Nobady answer me since.

Thank you for your answer

hi @nikolicsmilan77 where you able to find a solution to this?
I m having the same problem.
Thanks