Website not loading in the Philippines

I was watching my first lesson in ‘Data Analysis with Python Certification’ when the website suddenly stopped working. It happened as I was moving on to the next lesson–I answered the question and clicked enter. Before entering my answer, I also noticed a banner at the top of the page that says, “you appear to be offline, your progress may not be saved.” But I am online and other websites are loading perfectly fine on my Google Chrome .

I tried logging in using Safari on my iOS and the website is not loading there as well. I’m based in the Philippines. I’m able to login to the forums but when I click ‘Visit the Curriculum’ in the upper left corner of the page, the website stops loading again. :frowning:

2 Likes

Welcome there,

This happens every now and again. If there is no connection issue on your side, I assume it is an issue with your location, and the nearest CDN serving the scripts freeCodeCamp uses.

As we are not aware of any outages, there is little that can be done. Typically, this kind of issue is resolved with a bit of time, and a refresh of the browser page.

Hope you are able to get back to learning soon enough.

2 Likes

Thank you for your feedback. I also posted this issue on Reddit and it turns out I’m not the only one from PH who’s having the same issue. I hope this gets resolved soon.

Hi there, having the same issue just now. I am also from the Philippines… I mainly use Chrome. I tried using different browsers, clearing cache/browsing history… Nothing worked.

Hi @axigalactic !

I found your post on the reddit page.

I have made an issue on github.

1 Like

Hi @amarsonmayuyu1 !

Welcome to the forum!

I am sorry that you are experiencing technical difficulties.
I have made a post on github.

Hopefully the issue resolves itself.

Just to be clear, you are unable to access the curriculum at all.
Not even to log in?

Hello @jwilkins.oboe!

Yes, I hope it gets fixed soon. I could not even get to the login page. The browser tab shows the loader, but nothing happens.

Thanks for the follow-up!

1 Like

I have updated the issue with your screenshot.

You can follow along with the progress on the issue page.

2 Likes

Hi @jwilkins.oboe ! Yes, we’re unable to login as of now. Thank you for making an issue on github on our behalf. :sweat: I’ve already subscribed to the thread. Hope it gets resolved soon.

1 Like

Hi everyone,

We checked most things from our end and can’t trace the cause of the outage in the Philippines just yet. We would need some help with confirming a few things to help us figure out the root cause.

Can you confirm which of these apps are down for you?

English Language apps:
learn - our learning platform at: https://www.freecodecamp.org/learn.
news - our developer focused publication at: https://www.freecodecamp.org/news
forum - this community forum at: https://forum.freecodecamp.org
chat - our chat platform at: https://chat.freecodecamp.org

[Optional for additional insight]
Chinese language apps:
https://chinese.freecodecamp.org
https://chinese.freecodecamp.org/forum
https://chinese.freecodecamp.org/news

Spanish language apps:
https://www.freecodecamp.org/espanol/learn
https://www.freecodecamp.org/espanol/news

Please reply to this thread with the information in this format:

I can't access the below URLs:

- https://...
- https://...
- https://...

My user agent is:

Where the list is only the URLs that you can’t reach, and your user agent which you can get from Google with this search: https://www.google.com/search?q=what’s+my+user+agent

Thanks.

2 Likes

Additional sanity check:

It may be helpful to confirm if there is a posible issue with the DNS & our primary domain.

We have a version app of the freecodecamp’s learn application that we use internally for testing and development only.

If you can confirm the dev version of the site at freecodecamp.dev is available for you? For example the test version of learn app is avaiable at https://www.freecodecamp.dev/learn

If you are able to login above, this means we certainly could be having an issue with the primary domain freecodecamp.org.

Thanks for your help in helping us resolve this.

3 Likes

Hello @raisedadead! I just tried it and I am able to sign in now. Whatever your team did, it worked. Thank you so much!

1 Like

Hi, I can only input two links since I’m a new user. All the URLs provided (including the Chinese and Spanish websites) aren’t working on my end except for this forum (https://forum.freecodecamp.org) and the test version (https://www.freecodecamp.dev/learn). I tried logging in to the test version and I was able to do so.

My user agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36

1 Like

@amarsonmayuyu1

Thanks for confirming, but to be honest we haven’t done much yet. So, it looks like something intermittent with the ISP in your area.

@axigalactic

I have bumped you a couple of levels. You should be able to post more links now and give us some detailed feedback.

2 Likes

I can’t access the below URLs:

My user agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36

Thanks for sharing these details. As one more sanity check to rule out the ISP could you possibly test your connectivity with a VPN?

I can’t access the below URLs:

My user agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36 Edg/90.0.818.66

Heyyy! This worked for me

I’m from Philippines by the way

Is it okay to use the Test Version like for long-term? Even after a fix for the Prod Site is available? Noticed that it saved my progress on the Test Version and as long as it does that, it’s fine with me.