Why is my code Autocompleting?

Why is my code Autocompleting?
0

#1

How do I turn off this autocomplete feature? See picture for example:

When I go to type in something there are all these autocomplete options that I can’t get rid of. For example, if I try to type…

"this is great" + Enter

once I hit enter it will autocomplete to say “SVGPreserveAspectRatio”


#2

FCC uses Monaco as the code editor, which has IntelliSense (autocompletion) enabled by default. You may be able to find a way to disable IntelliSense in the documentation.

Workaround: click Esc to get rid of the autocomplete drop-down, then click Enter.


#3

Okay. Does this happen for everyone or is it just me? When I did some FCC several months ago I don’t remember this happening. Not fun to have to press ESC for every word lol.


#4

Also, would this have anything to do with VS Code? I noticed I have similar problems in VS Code but not in Sublime.


#5

It always happens for me. And yes, hitting Esc is annoying. :slightly_frowning_face:


#6

Sorry - it’s the other way around. VS Code is based on Monaco. Gah.


#7

Thanks, very helpful.


#8

Stumbled upon this by accident, don’t know if you solved it already, but you can disable the “accept on enter” behavior so it accepts on tab alone instead of enter. Setting is called “editor.acceptSuggestionOnEnter” just set to off. There’s also a “smart” setting but I haven’t found it to work well at all.


#9

Autocomplete is a good thing!


#10

Autocomplete has its pros and cons

Pros:

  • Can save you a visit to the documentation
  • Can save you time.

Cons:
  • Can get in the way while typing.
  • Can get in the way of your practice.