Celestial Bodies Database - Build a Celestial Bodies Database

Tell us what’s happening:
I finished the project, and uploaded the sql file on github. Then I tried to use copy Permal link on github on the sql file to paste the link to freecodecamp. But it says 'You must complete the Challenge first. I tried everything I found on forum, but it didn’t seem to work.
Your project link(s)

solution: https://github.com/amaliyal/freecodecamp/blob/main/universe.git

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Celestial Bodies Database - Build a Celestial Bodies Database

Link to the challenge:

Hello there, I’m having just the same challenge. any help please?

Hey! I’ve just figured out myself. If you include up to the repository name it would work, remove the file name.

I would need some help also. Some explicit steps on how to upload the universe.sql file to a public repository. I haven’t used github, even though I created an account specifically to participate to this certification. Thanks!

The easiest way of uploading your universe.sql file to GitHub is:

  1. Open the sql file in the CodeRoad project and copy the contents.
  2. Open up a notepad (or similar) app on your PC and paste the code.
  3. Save the file on the desktop as universe.sql.
  4. Create a repo on GitHub and then upload the file to it.
  5. Submit the repo link to FCC to complete the project.

Thank you, this is what I did eventually, but when I insert the link from github it doesn’t get accepted in freecodecamp

This happens when FCC hasn’t received confirmation of course completion from CodeRoad. You can try going back into the course on CodeRoad and then clicking Continue on the course completion message once more, then going back to FCC and refreshing the Celestial Bodies page before submitting the link again. If that doesn’t work, you can also try loading up a different course to generate a new user token and then going back and repeating all of the previous steps I mentioned again.
There have been connection issues with CodeRoad today but I think they might be resolved now.

1 Like

Thank you very much for the suggestion. I followed it and I was able to submit the link!

This needs to get moved to the top of the inquiry pile. Thank you!