Keep getting "you appear to be offline, so your progress may not be saved" error message

Hi, I’ve keep getting the " you appear to be offline so your progress may not be saved" error every time. I’ve tried logging out and back in several times and the problem persists. I have kept logging out and in several times in the past and it fixed the issue, but it keeps repeating regularly. Could someone please help? I’d really appreciate it. Thank you :slight_smile:

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.2 Safari/605.1.15.

I’m having the same problem today. I used to be able to re-login and get past this error msg “You appear to be offline, your progress may not be being saved.” at the top of the page but today, no matter how many times I login I’m unable to save my progress in the course if I try to continue. Please help!

Well, I tried even turning off “Prevent cross-site tracking” within Safari preferences and turned off my antivirus anti-tracker BitDefender and could not get Safari to work, so I gave Google Chrome browser a try, and shockingly, FreeCodeCamp just works perfectly with Google Chrome.

Is Safari just not supported any more for FreeCodeCamp? Just wondering.

Thanks,
Mike

Safari sometimes isn’t the best about following all web standards. Chrome is usually the best about adhering to standards.

Thanks Jeremy. Appreciate the feedback. Was hoping these incompatibilities were mostly behind Safari as I’ve been trying to use it as my main browser since it uses so much less power on my Mac, but this is the 3rd website I’ve run across that I need to use Chrome with rather than Safari in the last 6 months.

Thanks again,

  • Mike
1 Like

Hey! I tried logging in over and over again, but I could only get it to go away and work properly when I logged into the forum. This happened twice on two different days. The first time I signed up to the forum and then tried and it worked, and then on the other day I created this thread on here, and voila, it worked again. Thanks for the comment, I thought I was the only one this was happening to :slight_smile:

1 Like

Wow, I just tried the “logging into the forum” trick and that made Safari work for me again too! Thanks for the update! :smiley: