Learn Bash and SQL by building a bike rental shop file keeps getting deleted

Every time I complete one task and hit continue the bike-shop.sh file keeps getting deleted. For every new task I have to undo the deletion and provide executable permissions again. I think it is a bug.

Hi, welcome to the forums.

What browser are you using and is CodeAlly laggy or slow to boot up for you at all?

I’m using Brave and CodeAlly is not laggy or slow

I’m getting this error now

Does this still happen when using a different browser like Chrome? CodeAlly is really finicky even when everything’s working right and doesn’t seem to work reliably on Brave.

I checked on chrome too, same result

Did you ever get this issue before? I will admit that I had a hard time completing the relational database certification because of technical problems like that. Sometimes I just had to wait a few hours and try again.

I would recycle the VM and then give it a while if it still doesn’t work. If nothing else does it and it’s 100% not a browser/extension issue, you might have to delete the container and do it over; I had to do that for a lesson.

ihave the same problem here :frowning: now my script is 3 lessons back and i cant go further because the last 3 lessons are no longer in my scrpit

I passed this course. And often faced with such a problem. Restarting the VM, clicking on reset did not help. I had to delete the VM and start from the beginning. Some parts three times.

You can always go back and do the previous steps by going to the Menu > Review
Also it is good to keep a copy of your completed script in a txt file. That’s what I am doing.