CodeAlly deletes my progress

I am doing the Bike Rental Shop course and I’ve progressed quite a lot. But after the “create an AVAILABLE_BIKES variable” task I encountered a nasty bug.

  1. I complete the task. The system counts it as completed, gives me a green mark and I pass to the next step…
  2. After the next step loads all the files are deleted (the and the database starts giving me errors too. (I check with ls command - my shell file isn’t there.) So I reload the page and reconnect to CodeAlly.
  3. When I reload it it gives me the version of the bike-shop shell file and the version of the database from before I completed the task. The task, though, still counts as completed. I change the file and the database again and then complete the next task… and then the same thing repeats - and I have to start from the same step I got stuck in (although the tasks I complete in this weird way are saved as “completed”).

I am going to reset this course, which is a shame, for I’ve already spent a couple of hours on it.

P.S. After resetting I found out that I actually didn’t loose my progress. The files were replaced by the standard ones for the task I am currently doing (which I’m fine with). That was a pleasant surprise!
P.P.S. Sadly, the bug continues. Everything gets deleted and I have to click the reset button to continue working every single time I complete a task.

1 Like

Similar problem happened to me.
ı have started my bike and rentals shop course and completed task by task until created After this task ı have wrote bin bash and echo task in my file. when I wrote writable attribute my file has deleted. ı have used soft rest but same problem has happened. and I tried ways other restarts reloads also restart my computer.

still the problem persists and additional the vs code screen loading my browser but no launch coderoad. this screen viewing over and over minutes. please help me. please give me a suggestion or say to me what is happening?

In my case the bug went away on its own. I reconnected after waiting a day and everything was working properly. Also don’t forget to clear the cache - that might help as well.

1 Like

thanks for your interest and sugggestion but I’ve just tried your suggesstion but it didn’t work. since yesterday ı have signed in and loading visual code but coadroad cannot launch tutorial and there isn’t myfile in my project bar. there is some problem but ı dont know what kind of…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.