Learn Git by Building an SQL Reference Object - corrupted git repo?

Hello ! I’m trying to complete this course, and around 75% completion, We are asked to run the following command :

git rebase --interactive --root

but it seems like I cannot access the earlier commits of my repo, as running a simple git log --oneline, only prints a bout 10 commits before printing

0ae0bd4 feat: add drop table reference
18f0344 feat: add create table reference
error: Could not read a5de9441f554604a1418a7ea46d836ea9ca09613
fatal: Failed to traverse parents of commit 684afe786ecb33e590f7dd03d9d53b6b7770684d

My guess is that the .git folder is somehow corrupted ?
The reset button and soft restart did not fix this. I really hope there’s another way than deleting the container as I dread redoing the 300 steps that let me to this …

Any help would be appreciated !

Hello, have you tried to perform a soft reset, that might help. I had a similar problem and the reset returned me to the previous step…

Above the hamburger, :), there is another menu in light green, there you can select to do a soft reset.

I had a similar problem in this task. Looking around this forum I saw a gentleman sugesting change your directory to the folder that is been used on the task. In my case I used “cd sql_reference” before using the others commands that the task is asking for. It worked for me.
Reference: sandy13 BUG: Got kicked out, Lost all progress/branches and Unable to move forward in lesson (Relational Database Cert > Learn Git by Building an SQL Reference Object )

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.