SSH help with Android and Linux

SSH help with Android and Linux
0.0 0

#1

I’m trying to connect to my Linux Mint machine using JuiceSSH on my android phone and am having no luck.

I confirmed my SSH server is running using the “systemctl is-active ssh” command.

Next I added “AllowUsers yourusername” to the bottom of my “sshd_config” file and then restarted the server with “sudo /etc/init.d/ssh restart”

I found my IP address using ifconfig and am using the default 22 port (for now)

I am unable to connect using my Linux username / password with these settings in JuiceSSH, is there something that I’m missing?

I remember doing this with putty when I was 13 and can’t get it to work at 30…


#2

Try it on a normal machine first. Can you connect from localhost? Can you connect from a different computer?


#3

Just based on what i cant see:

Assuming you’re not trying locally then is the port open on the router?

Have you allowed incoming connections on port 22 through firewall?

Have you set up the identity fully in juicessh i remember it being awkward.
And yeah try to ssh localhost:22 or lan ip from another nix or mac box.

Dont forget to turn on cert key authentification and to disable password logins. Far more secure than obfuscating which port you use. And juice has handy keygen amd snippets to upload and append new cert key to authorised keys file.


#4

What error message are you getting?


#5

Can’t believe I forgot to add the new firewall rules, thanks! Thanks for the other tips too used them as well.